#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)£[5-9]\d{2,}|£[1-9]\d{3,}"
Local $sString = "Line 60166: £5.99" & @CRLF & _
"Line 60294: £59.99" & @CRLF & _
"Line 60493: £5.53" & @CRLF & _
"Line 60619: £5.19" & @CRLF & _
"Line 60829: £5.88" & @CRLF & _
"Line 60847: £5.18" & @CRLF & _
"Line 61508: £5.98" & @CRLF & _
"Line 61771: £5.27" & @CRLF & _
"Line 61777: £5.99" & @CRLF & _
"Line 61789: £5.49" & @CRLF & _
"Line 61893: £5.00" & @CRLF & _
"Line 61899: £56.49" & @CRLF & _
"Line 61940: £500.91" & @CRLF & _
"Line 23832: £9484.94" & @CRLF & _
"Line 23832: £944.94" & @CRLF & _
"Line 23832: £94.94" & @CRLF & _
"Line 23832: £584.94" & @CRLF & _
"Line 23832: £1484.94"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")