import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "£[5-9]\\d{2,}|£[1-9]\\d{3,}";
final String string = "Line 60166: £5.99\n"
+ "Line 60294: £59.99\n"
+ "Line 60493: £5.53\n"
+ "Line 60619: £5.19\n"
+ "Line 60829: £5.88\n"
+ "Line 60847: £5.18\n"
+ "Line 61508: £5.98\n"
+ "Line 61771: £5.27\n"
+ "Line 61777: £5.99\n"
+ "Line 61789: £5.49\n"
+ "Line 61893: £5.00\n"
+ "Line 61899: £56.49\n"
+ "Line 61940: £500.91\n"
+ "Line 23832: £9484.94\n"
+ "Line 23832: £944.94\n"
+ "Line 23832: £94.94\n"
+ "Line 23832: £584.94\n"
+ "Line 23832: £1484.94";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}