# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"£[5-9]\d{2,}|£[1-9]\d{3,}"
test_str = ("Line 60166: £5.99\n"
"Line 60294: £59.99\n"
"Line 60493: £5.53\n"
"Line 60619: £5.19\n"
"Line 60829: £5.88\n"
"Line 60847: £5.18\n"
"Line 61508: £5.98\n"
"Line 61771: £5.27\n"
"Line 61777: £5.99\n"
"Line 61789: £5.49\n"
"Line 61893: £5.00\n"
"Line 61899: £56.49\n"
"Line 61940: £500.91\n"
"Line 23832: £9484.94\n"
"Line 23832: £944.94\n"
"Line 23832: £94.94\n"
"Line 23832: £584.94\n"
"Line 23832: £1484.94")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.