package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)£[5-9]\d{2,}|£[1-9]\d{3,}`)
var str = `Line 60166: £5.99
Line 60294: £59.99
Line 60493: £5.53
Line 60619: £5.19
Line 60829: £5.88
Line 60847: £5.18
Line 61508: £5.98
Line 61771: £5.27
Line 61777: £5.99
Line 61789: £5.49
Line 61893: £5.00
Line 61899: £56.49
Line 61940: £500.91
Line 23832: £9484.94
Line 23832: £944.94
Line 23832: £94.94
Line 23832: £584.94
Line 23832: £1484.94`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}