use strict;
my $str = 'Alguien tiene alguna imagen donde se vea donde tirar las sondas para escanear planetas?
tiro sondas?
lanzar sondas?
lanzo sonda?
mapear planetas?
uso las sondas?
disparan sondas?
usas las sondas?
usa las sondas?
usais las sondas?';
my $regex = qr/(.+?|)(tir(a|o)?|dispar(a|o)?|lanz(a|o)?|mape(a|o)?|us(o|a)?)(.+?|)(sonda|planeta|burbuja|mater?)(.+?|)\?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}