import re
regex = re.compile(r"(.+?|)(tir(a|o)?|dispar(a|o)?|lanz(a|o)?|mape(a|o)?|us(o|a)?)(.+?|)(sonda|planeta|burbuja|mater?)(.+?|)\?", flags=re.MULTILINE)
test_str = ("Alguien tiene alguna imagen donde se vea donde tirar las sondas para escanear planetas?\n\n"
"tiro sondas?\n\n"
"lanzar sondas?\n\n"
"lanzo sonda?\n\n"
"mapear planetas?\n\n"
"uso las sondas?\n\n"
"disparan sondas?\n\n"
"usas las sondas?\n\n"
"usa las sondas?\n\n\n"
"usais las sondas?")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")