using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\G(?!\A)|\[)[^]\s]*\K\s+";
string substitution = @"$";
string input = @"[Edit the] Expression & [Text to see matches]. Roll [over matches or the] expression for details. Undo mistakes with ctrl-z. [Save Favorites and Share expressions with friends] or the Community. Explore your results with Tools. [A full Reference and Help is available in the Library or watch the video Tutorial].";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}