const regex = /(?:\G(?!\A)|\[)[^]\s]*\K\s+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\G(?!\\A)|\\[)[^]\\s]*\\K\\s+', 'g')
const str = `[Edit the] Expression & [Text to see matches]. Roll [over matches or the] expression for details. Undo mistakes with ctrl-z. [Save Favorites and Share expressions with friends] or the Community. Explore your results with Tools. [A full Reference and Help is available in the Library or watch the video Tutorial].`;
const subst = `$`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);