import Foundation
let pattern = #"(?:\G(?!\A)|\[)[^]\s]*\K\s+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"[Edit the] Expression & [Text to see matches]. Roll [over matches or the] expression for details. Undo mistakes with ctrl-z. [Save Favorites and Share expressions with friends] or the Community. Explore your results with Tools. [A full Reference and Help is available in the Library or watch the video Tutorial]."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)