use strict;
my $str = '[Edit the] Expression & [Text to see matches]. Roll [over matches or the] expression for details. Undo mistakes with ctrl-z. [Save Favorites and Share expressions with friends] or the Community. Explore your results with Tools. [A full Reference and Help is available in the Library or watch the video Tutorial].';
my $regex = qr/(?:\G(?!\A)|\[)[^]\s]*\K\s+/p;
my $subst = '$';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";