using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^(\/]+)(?:\((.*?)\))?\/(?:([^?]+))?\?select=(.*)$";
string input = @"Table_name(1)/field?select=Name
Table_name/field?select=Name
bla-bla-bla(123)/zsdfgdsg?select=Name2
bla-bla-bla(897646)/rytutuityi?select=Name3
Table_name(1)/?select=Name
Table_name(1)/?select=Name";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}