import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^(\\/]+)(?:\\((.*?)\\))?\\/(?:([^?]+))?\\?select=(.*)$";
final String string = "Table_name(1)/field?select=Name\n"
+ "Table_name/field?select=Name\n"
+ "bla-bla-bla(123)/zsdfgdsg?select=Name2\n"
+ "bla-bla-bla(897646)/rytutuityi?select=Name3\n"
+ "Table_name(1)/?select=Name\n"
+ "Table_name(1)/?select=Name";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}