const regex = /^([^(\/]+)(?:\((.*?)\))?\/(?:([^?]+))?\?select=(.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([^(\\\/]+)(?:\\((.*?)\\))?\\\/(?:([^?]+))?\\?select=(.*)$', 'gm')
const str = `Table_name(1)/field?select=Name
Table_name/field?select=Name
bla-bla-bla(123)/zsdfgdsg?select=Name2
bla-bla-bla(897646)/rytutuityi?select=Name3
Table_name(1)/?select=Name
Table_name(1)/?select=Name`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}