# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:\bid="|(?!^)\G)[^\s"]*\K\s+//g;t' <<< "<div id=\"transcending intellectual limitations\">
<div id=\"tr ans\">
<div id=\"hel lo\">
</div>
</div>
</div>"