$re = '/(?:\bid="|(?!^)\G)[^\s"]*\K\s+/';
$str = '<div id="transcending intellectual limitations">
<div id="tr ans">
<div id="hel lo">
</div>
</div>
</div>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;