import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\bid=\"|(?!^)\\G)[^\\s\"]*\\K\\s+";
final String string = "<div id=\"transcending intellectual limitations\">\n"
+ " <div id=\"tr ans\">\n"
+ " <div id=\"hel lo\">\n\n"
+ " </div>\n"
+ " </div>\n"
+ "</div>";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}