import Foundation
let pattern = #"(?:\bid="|(?!^)\G)[^\s"]*\K\s+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<div id="transcending intellectual limitations">
<div id="tr ans">
<div id="hel lo">
</div>
</div>
</div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)