# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\G((?:(?:"(?:\\[\S\s]|[^"\\])*"|'(?:\\[\S\s]|[^'\\])*')|[^"'\s]+)*)\s+/$1 /g;t' <<< "'example' another_word"