import re
regex = re.compile(r"\G((?:(?:\"(?:\\[\S\s]|[^\"\\])*\"|'(?:\\[\S\s]|[^'\\])*')|[^\"'\s]+)*)\s+")
test_str = "'example' another_word"
subst = "$1 "
result = regex.sub(subst, test_str)
if result:
print(result)