import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:[\\s\\w]*(?:(\\{(?:[\\s\\w]*%\\(\\w*\\)[\\s\\w]*)+(?:\\{(?:[\\s\\w]*%\\(\\w*\\)[\\s\\w]*)+\\})*\\})+)[\\s\\w]*)+)$";
final String string = "# Your valid example\n"
+ "abc {st1 %(ph1) st11} int {st2 %(ph2) st22}{st3 %(ph3) st33 {st31 %(ph4) st332}} cd\n\n"
+ "# Your valid Legenda\n"
+ "OptionalStaticText{OptionalStaticText %(Placeholder) OptionalStaticText {OptionalSubSection} OptionalStaticText} OptionalStaticText\n\n"
+ "# Your invalid example\n"
+ "abc {st1 %(ph1) st11} int {st2 %(ph2) st22}{st3 %(ph3) st33 {st31 %(ph4) st332}} c-d\n\n\n"
+ "# Without pre / post optional static text and some optional text inside section\n"
+ "{%(Placeholder) OptionalStaticText {OptionalSubSection}}\n\n"
+ "# With only a placeholder in the section\n"
+ "OptionalStaticText{%(Placeholder)} OptionalStaticText\n\n"
+ "# The valid version\n"
+ "abc {st1 %(ph1) st11} int {st2 %(ph2) st22}{st3 %(ph3) st33 {st31 %(ph4) st332}} cd\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}