using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d*\.zip)";
string input = @"http://llpdata.tgs.com/DataDelivery1/LogLine1//14815/2011905/2569689.zip";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}