re = /(\d*\.zip)/
str = 'http://llpdata.tgs.com/DataDelivery1/LogLine1//14815/2011905/2569689.zip'
# Print the match result
str.match(re) do |match|
puts match.to_s
end