const regex = /(\d*\.zip)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d*\\.zip)', '')
const str = `http://llpdata.tgs.com/DataDelivery1/LogLine1//14815/2011905/2569689.zip`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}