package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d*\.zip)`)
var str = `http://llpdata.tgs.com/DataDelivery1/LogLine1//14815/2011905/2569689.zip`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}