import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^-?(?:0|[1-9]\\d*)(?:_\\d+)*(?:\\.\\d+(?:_\\d+)*)?$";
final String string = "1_2.3_4\n"
+ "1\n"
+ "-1\n"
+ "1.2\n"
+ "-1.2\n"
+ "0\n"
+ "0.00\n"
+ "0.1\n"
+ "000_00.00\n"
+ "0000";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}