import re
regex = re.compile(r"^-?(?:0|[1-9]\d*)(?:_\d+)*(?:\.\d+(?:_\d+)*)?$", flags=re.MULTILINE)
test_str = ("1_2.3_4\n"
"1\n"
"-1\n"
"1.2\n"
"-1.2\n"
"0\n"
"0.00\n"
"0.1\n"
"000_00.00\n"
"0000")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")