const regex = /^-?(?:0|[1-9]\d*)(?:_\d+)*(?:\.\d+(?:_\d+)*)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^-?(?:0|[1-9]\\d*)(?:_\\d+)*(?:\\.\\d+(?:_\\d+)*)?$', 'gm')
const str = `1_2.3_4
1
-1
1.2
-1.2
0
0.00
0.1
000_00.00
0000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}