#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!(?:.*?\d+\b){2})(?=.*\d)[a-zA-Z0-9 ]+$"
Local $sString = "Salary amount 20000" & @CRLF & _
"" & @CRLF & _
"Please increase amount 3000" & @CRLF & _
"" & @CRLF & _
"xyz 3000 yxed abc" & @CRLF & _
"asas aswas 200 asa 300 asa 3300" & @CRLF & _
"" & @CRLF & _
"xyd rooo 4000 3" & @CRLF & _
"xyz yxed abc"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")