use strict;
my $str = 'Salary amount 20000
Please increase amount 3000
xyz 3000 yxed abc
asas aswas 200 asa 300 asa 3300
xyd rooo 4000 3
xyz yxed abc';
my $regex = qr/^(?!(?:.*?\d+\b){2})(?=.*\d)[a-zA-Z0-9 ]+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}