const regex = /^(?!(?:.*?\d+\b){2})(?=.*\d)[a-zA-Z0-9 ]+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!(?:.*?\\d+\\b){2})(?=.*\\d)[a-zA-Z0-9 ]+$', 'gm')
const str = `Salary amount 20000
Please increase amount 3000
xyz 3000 yxed abc
asas aswas 200 asa 300 asa 3300
xyd rooo 4000 3
xyz yxed abc`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}