$re = '/^(?!(?:.*?\d+\b){2})(?=.*\d)[a-zA-Z0-9 ]+$/m';
$str = 'Salary amount 20000
Please increase amount 3000
xyz 3000 yxed abc
asas aswas 200 asa 300 asa 3300
xyd rooo 4000 3
xyz yxed abc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);