const regex = new RegExp('(?P<Month>(?:01|02|03|04|05|06|07|08|09|10|11|1|2|1|2|3|4|5|6|7|8|9|Jan|Feb|Mar|Apr|May|Jun|Jul|Aug|Sep|Oct|Nov|Dec|January|February|March|April|May|June|July|August|September|October|November|December))[\\-/\\\\\\s]+(?P<Day>[0-3]?\\d)[\\-/\\\\\\s]+(?P<Year>\\d+)', 'gi')
const str = `1-2-1995`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}