$re = '/(?P<Month>(?:01|02|03|04|05|06|07|08|09|10|11|1|2|1|2|3|4|5|6|7|8|9|Jan|Feb|Mar|Apr|May|Jun|Jul|Aug|Sep|Oct|Nov|Dec|January|February|March|April|May|June|July|August|September|October|November|December))[\-/\\\\\s]+(?P<Day>[0-3]?\d)[\-/\\\\\s]+(?P<Year>\d+)/i';
$str = '1-2-1995';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);