#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?:\w+(?:[_.-]\w+)*)|\$test\$)$"
Local $sString = "test" & @CRLF & _
"test-5" & @CRLF & _
"test.1.3" & @CRLF & _
"test-alpha.2" & @CRLF & _
"$test$" & @CRLF & _
"" & @CRLF & _
"But not..." & @CRLF & _
"" & @CRLF & _
"$test" & @CRLF & _
"test$"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")