using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?:\w+(?:[_.-]\w+)*)|\$test\$)$";
string input = @"test
test-5
test.1.3
test-alpha.2
$test$
But not...
$test
test$";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}