// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:(?:\w+(?:[_.-]\w+)*)|\$test\$)$").unwrap();
let string = "test
test-5
test.1.3
test-alpha.2
$test$
But not...
$test
test$";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}