package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^I am on \(([^)]*)\) page$`)
var str = `I am on (Similar Article Alerts|Search Alerts|Journal Alerts) page`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}