re = /^I am on \(([^)]*)\) page$/m
str = 'I am on (Similar Article Alerts|Search Alerts|Journal Alerts) page'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end