const regex = /^I am on \(([^)]*)\) page$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^I am on \\(([^)]*)\\) page$', 'gm')
const str = `I am on (Similar Article Alerts|Search Alerts|Journal Alerts) page`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}