$re = '/^I am on \(([^)]*)\) page$/m';
$str = 'I am on (Similar Article Alerts|Search Alerts|Journal Alerts) page';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);