using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)(?:\b(tree)\b)(?:(?!\n)\W)+(?:\w+\W+){0,5}?\b(house)\b.*";
string substitution = @"";
string input = @"here is a tree with a house
here is a tree
with a house";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}