import re
regex = re.compile(r"(?i)(?:\b(tree)\b)(?:(?!\n)\W)+(?:\w+\W+){0,5}?\b(house)\b.*")
test_str = ("here is a tree with a house\n"
"here is a tree \n"
"with a house")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)