const regex = /(?i)(?:\b(tree)\b)(?:(?!\n)\W)+(?:\w+\W+){0,5}?\b(house)\b.*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)(?:\\b(tree)\\b)(?:(?!\\n)\\W)+(?:\\w+\\W+){0,5}?\\b(house)\\b.*', 'g')
const str = `here is a tree with a house
here is a tree
with a house`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);