import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)(?:\\b(tree)\\b)(?:(?!\\n)\\W)+(?:\\w+\\W+){0,5}?\\b(house)\\b.*";
final String string = "here is a tree with a house\n"
+ "here is a tree \n"
+ "with a house";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}