using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"__\((['""])((?:\\\1|(?!\1).)*)\1\)";
string input = @"
echo __('simple quoted: I don\'t ""see"" what is wrong');
echo __(""double quoted: I don't \""see\"" what is wrong"");";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}