import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "__\\((['\"])((?:\\\\\\1|(?!\\1).)*)\\1\\)";
final String string = "\n"
+ "echo __('simple quoted: I don\\'t \"see\" what is wrong');\n"
+ "echo __(\"double quoted: I don't \\\"see\\\" what is wrong\");";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}