$re = '/__\(([\'"])((?:\\\\\1|(?!\1).)*)\1\)/s';
$str = '
echo __(\'simple quoted: I don\\\'t "see" what is wrong\');
echo __("double quoted: I don\'t \\"see\\" what is wrong");';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);