re = /__\((['"])((?:\\\1|(?!\1).)*)\1\)/
str = '
echo __(\'simple quoted: I don\\\'t "see" what is wrong\');
echo __("double quoted: I don\'t \\"see\\" what is wrong");'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end