import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-Z]+)";
final String string = "'coordinatorCountry': 'coordinator_country',\n"
+ "'ecContribution': 'ec_contribution',\n"
+ "'ecMaxContribution': 'ec_max_contribution',\n"
+ "'endDate': 'end_date',\n"
+ "'frameworkProgramme': 'framework_programme',\n"
+ "'fundingScheme': 'funding_scheme',\n"
+ "'participantCountries': 'participant_countries',\n"
+ "'projectUrl': 'project_url',\n"
+ "'startDate': 'start_date',\n"
+ "'totalCost': 'total_cost',\n"
+ "'activityType': 'activity_type',\n"
+ "'ecCContribution': 'ec_contribution',\n"
+ "'endOfParticipation': 'end_of_participation',\n"
+ "'organizationUrl': 'organization_url',\n"
+ "'postCode': 'post_code',\n"
+ "'shortName': 'short_name',\n"
+ "'vatNumber': 'vat_number',\n"
+ "'projectID': 'project_id',";
final String subst = "_\\L$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}