// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([A-Z]+)").unwrap();
let string = "'coordinatorCountry': 'coordinator_country',
'ecContribution': 'ec_contribution',
'ecMaxContribution': 'ec_max_contribution',
'endDate': 'end_date',
'frameworkProgramme': 'framework_programme',
'fundingScheme': 'funding_scheme',
'participantCountries': 'participant_countries',
'projectUrl': 'project_url',
'startDate': 'start_date',
'totalCost': 'total_cost',
'activityType': 'activity_type',
'ecCContribution': 'ec_contribution',
'endOfParticipation': 'end_of_participation',
'organizationUrl': 'organization_url',
'postCode': 'post_code',
'shortName': 'short_name',
'vatNumber': 'vat_number',
'projectID': 'project_id',";
let substitution = "_\\L$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}